[Java] 蓝桥杯PREV-5 历届试题 错误票据

栏目: Java · 发布时间: 6年前

内容简介:问题描述输入格式要求程序首先输入一个整数N(N<100)表示后面数据行数。 接着读入N行数据。 每行数据长度不等,是用空格分开的若干个(不大于100个)正整数(不大于100000),请注意行内和行末可能有多余的空格,你的程序需要能处理这些空格。 每个整数代表一个ID号。

问题描述

某涉密单位下发了某种票据,并要在年终全部收回。

每张票据有唯一的ID号。全年所有票据的ID号是连续的,但ID的开始数码是随机选定的。

因为工作人员疏忽,在录入ID号的时候发生了一处错误,造成了某个ID断号,另外一个ID重号。

你的任务是通过编程,找出断号的ID和重号的ID。

输入格式

要求程序首先输入一个整数N(N<100)表示后面数据行数。 接着读入N行数据。 每行数据长度不等,是用空格分开的若干个(不大于100个)正整数(不大于100000),请注意行内和行末可能有多余的空格,你的程序需要能处理这些空格。 每个整数代表一个ID号。

输出格式

要求程序输出1行,含两个整数m n,用空格分隔。

样例输入1

2

5 6 8 11 9

样例输出1

7 9

样例输入2

6

164 178 108 109 180 155 141 159 104 182 179 118 137 184 115 124 125 129 168 196

172 189 127 107 112 192 103 131 133 169 158

128 102 110 148 139 157 140 195 197

185 152 135 106 123 173 122 136 174 191 145 116 151 143 175 120 161 134 162 190

149 138 142 146 199 126 165 156 153 193 144 166 170 121 171 132 101 194 187 188

样例输出2

105 120

package prev5;
 
import java.util.Scanner;
 
public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int n = in.nextInt();
        in.nextLine();
 
        int min = 100000;
        int max = 0;
        int[] corrent = new int[100000];
        for (int i = 0; i < n; i++) {
            String[] id = in.nextLine().split(" ");
 
            for (int j = 0; j < id.length; j++) {
                if (!id[j].equals("")) {
                    int num = Integer.parseInt(id[j]);
                    corrent[num]++;
 
                    if (num < min) {
                        min = num;
                    }
 
                    if (max < num) {
                        max = num;
                    }
                }
            }
        }
 
        int dupilcate = 0, emp = 0;
        for (int i = min; i <= max; i++) {
            if (corrent[i] == 0) {
                emp = i;
            } else if (corrent[i] == 2) {
                dupilcate = i;
            }
        }
 
        System.out.println(emp + " " + dupilcate);
        in.close();
    }
 
}
❤❤点击这里 -> 订阅PAT、蓝桥杯、GPLT天梯赛、LeetCode题解离线版❤❤ [Java] 蓝桥杯PREV-5 历届试题 错误票据

以上就是本文的全部内容,希望对大家的学习有所帮助,也希望大家多多支持 码农网

查看所有标签

猜你喜欢:

本站部分资源来源于网络,本站转载出于传递更多信息之目的,版权归原作者或者来源机构所有,如转载稿涉及版权问题,请联系我们

Distributed Algorithms

Distributed Algorithms

Nancy A. Lynch / Morgan Kaufmann / 1996-3-15 / USD 155.00

In "Distributed Algorithms", Nancy Lynch provides a blueprint for designing, implementing, and analyzing distributed algorithms. She directs her book at a wide audience, including students, programmer......一起来看看 《Distributed Algorithms》 这本书的介绍吧!

图片转BASE64编码
图片转BASE64编码

在线图片转Base64编码工具

Base64 编码/解码
Base64 编码/解码

Base64 编码/解码

正则表达式在线测试
正则表达式在线测试

正则表达式在线测试